Server Status

Server Outage 12/17/2024

Incident Report for TopSpin 2K Status Page

Resolved

This incident has been resolved.
Posted Dec 18, 2024 - 00:04 UTC

Update

We are continuing to work on a fix for this issue.
Posted Dec 17, 2024 - 23:14 UTC

Update

We are continuing to work on a fix for this issue.
Posted Dec 17, 2024 - 23:12 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Dec 17, 2024 - 20:05 UTC
This incident affected: FEATURE (Centre Court Pass, Pro Shop, Cross-Play, Friend Invites, Daily Challenges, Weekly Challenges, In Game Messaging, Locker Codes), GAME MODE (World Tour, 2K Tour, Online Exhibition, MyCAREER), and PLATFORMS (PlayStation™ Network, Xbox Live, Steam Servers).